Problem Closing APP

Oct 13, 2009 at 11:31 PM

I noticed that the example c# app does not free itself from memory when closing the app. I've noticed it only happens when allowing the port code to init. Each time I ran the app, another one showed up in the spy process. I created a separate app that used the code and noticed the same thing, anytime the app opened the GPS port and then closed, it appears the app is gone, but it's not. I did get accurate GPS data, I'm positive I'm using the correct port and baud rate. Just wondering if anyone else noticed this? I tried it on a few different devices, using windows mobile 5 and 6. I used the c# example as how to connect and disconnect from the port.

May 25, 2012 at 3:57 AM

Yes, this problem exists, I have lost days trying different ways how to avoid this, my application won't start again, only soft reboot helps

I noticed that on WIN CE 5.0 everything is ok, but this error comes up in WIN CE 6.0

I use the latest source for OpenNETCF.IO.Serial and the latest dlls OpenNETCF 2.3.12004

I would appreciate a lot if someone has solved this problem successfully